Assalamu'alaikum Warahmatullahi Wabarakatuh
Alhamdulillah dikasih kesempatan lagi buat corat coret di blog kesayangan hehehehe....sesuai dengan janji saya di artikel sebelumnya, kali ini kita akan coba bahas RIP sebagai salah satu routing protocol distance vector. Routing protocol ini hanya mengetahui informasi dari tetangganya. RIP menggunakan UDP port 520 sebagai transport.
Seperti yang di bahas di artikel sebelumnya saya sudah sempat kasih gambar / bagan dari routing protocol dan disitu dikasih liat bahwa RIP ada 2 versi yaitu versi 1 dan 2 (yaiyalah....kan 2 versi), bedanya apa sih? Nih bedanya bro....
Version 1
- Classfull Network
- Update dikirim sebagai broadcast
Version 2Seperti halnya distance vectore lainnya, RIP juga memiliki mekanisnya Split Horizone (apa lagi itu). Split Horizone ini adalah sebuah mekanisme untuk mencegah terjadinya routing loop di network kita. Cara kerjanya sangat sederhana, yaitu dengan tidak mengirimkan update ke interface dimana dia mendapatkan update. Coba lihat contoh berikut:
- Classless Network
- Update dikirim sebagai multicast ke 224.0.0.9
R1 misalnya memiliki beberapa network seperti berikut:
- 10.10.1.0/24
- 10.10.2.0/24
- 10.10.3.0/24
R1 akan melakukan advertisement network diatas ke R2. Nah....mekanisme splite horizone akan memastikan bahwa R2 tidak akan melakukan advertisement network diatas kembali ke R1 karena R2 sudah mendapatkan advertisement tersebut dari R1.
Oke, selanjutnya kita akan coba membuat labnya untuk melihat perbedaan antara RIPv1 dan RIPv2 ketika sudah di konfigurasi di router kita.
Untuk topology kita buat seperti gambar di atas saja ya, kita langsung masuk ke konfigurasinya, berikut saya capture hasil konfigurasi saya.
hostname R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.252
router rip
network 0.0.0.0
no auto-summary
hostname R2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.252
interface FastEthernet0/1
ip address 23.23.23.1 255.255.255.252
router rip
network 0.0.0.0
no auto-summary
hostname R3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.252
router rip
network 0.0.0.0
no auto-summary
Disetiap router kita aktifkan routing RIP nya dengan command berikut:
router rip
network 0.0.0.0
no auto-summary
Saya masukkan network 0.0.0.0 karena mau advertise semua network yang ada di router itu, biar gak masukin satu persatu jadinya saya masukin aja 0.0.0.0. Ini adalah RIPv1 yang sedang kita buat nanti kita lihat bedanya dentan RIPv2 seperti apa.
Cek table routing di semua router
R1#sh ip ro | b Gate
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
R 2.0.0.0/8 [120/1] via 12.12.12.2, 00:00:09, FastEthernet0/0
R 3.0.0.0/8 [120/1] via 12.12.12.2, 00:00:09, FastEthernet0/0
R 23.0.0.0/8 [120/1] via 12.12.12.2, 00:00:09, FastEthernet0/0
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/0
R1#
R2#sh ip route | begin Gate
Gateway of last resort is not set
R 1.0.0.0/8 [120/1] via 12.12.12.1, 00:00:24, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 23.23.23.2, 00:00:22, FastEthernet0/1
23.0.0.0/30 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/1
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/0
R2#
R3#sh ip route | begin Gate
Gateway of last resort is not set
R 1.0.0.0/8 [120/1] via 23.23.23.1, 00:00:20, FastEthernet0/0
R 2.0.0.0/8 [120/1] via 23.23.23.1, 00:00:20, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
23.0.0.0/30 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/0
R 12.0.0.0/8 [120/1] via 23.23.23.1, 00:00:20, FastEthernet0/0
R3#
Kita debug IP RIP nya di R1 untuk melihat proses apa saja yang terjadi di RIPv1 ini
R1#debug ip rip
R1#
*Mar 1 00:05:13.879: RIP: received v1 update from 12.12.12.2 on FastEthernet0/0
*Mar 1 00:05:13.883: 2.0.0.0 in 1 hops
*Mar 1 00:05:13.883: 3.0.0.0 in 1 hops
*Mar 1 00:05:13.883: 23.0.0.0 in 1 hops
Oke bisa kita liat di bagian debug proses transportnya classfull ya, sekarang kita coba ganti ke RIPv2 dan kita lihat nanti hasil debug.
Ubah bagian command ini ya,
router rip
version 2
network 0.0.0.0
no auto-summary
Cek lagi table routingnya seperti apa sekarang ya?
R1(config-router)#do sh ip ro | b Gate
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 2.2.2.2/32 [120/1] via 12.12.12.2, 00:00:11, FastEthernet0/0
R 2.0.0.0/8 [120/1] via 12.12.12.2, 00:02:25, FastEthernet0/0
3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 3.3.3.3/32 [120/2] via 12.12.12.2, 00:00:11, FastEthernet0/0
R 3.0.0.0/8 [120/2] via 12.12.12.2, 00:00:11, FastEthernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 23.23.23.0/30 [120/1] via 12.12.12.2, 00:00:11, FastEthernet0/0
R 23.0.0.0/8 [120/1] via 12.12.12.2, 00:02:25, FastEthernet0/0
12.0.0.0/30 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/0
R1(config-router)#
Cek update routingnya seperti apa sekarang
R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:37:57.667: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (12.12.12.1)
*Mar 1 00:37:57.667: RIP: build update entries
*Mar 1 00:37:57.667: 1.1.1.1/32 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:37:58.315: RIP: sending v2 update to 224.0.0.9 via Loopback0 (1.1.1.1)
*Mar 1 00:37:58.315: RIP: build update entries
*Mar 1 00:37:58.315: 2.2.2.2/32 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:37:58.319: 3.3.3.3/32 via 0.0.0.0, metric 3, tag 0
*Mar 1 00:37:58.319: 12.12.12.0/30 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:37:58.319: 23.23.23.0/30 via 0.0.0.0, metric 2, tag 0
R1#
Wah sekarang sudah menggunakan multicast ya, terlihat IP 224.0.0.9 sudah muncul yang sebelumnya di RIPv1 yang muncul adalah ip 12.12.12.2. Oke pembuktiannya sudah berhasil,,,saatnya kita berpisah di pertemuan kali ini, terima kasih sudah mampir.....
Wassalamu'alaikum Warahmatullahi Wabarakatuh
Comments
Post a Comment
Komentar spam, menyertakan link aktif dan alamat blog tidak akan muncul. Tidak semua pertanyaan sempat atau bisa dijawab. Thanks for visiting and the comment :)